文档中心 Object Storage API AbortMultipartUpload

AbortMultipartUpload

更新时间:2025-08-18 15:54:05

你可以调用 AbortMultipartUpload 以终止分段上传任务。请注意,在你调用 AbortMultipartUpload 或 CompleteMultipartUpload 之后,UploadPart 和 ListParts 接口将不可用,对象已上传分片所占用的存储空间也会被释放。此外,正在进行中的上传任务也不会成功。

因此,你可能需要多次调用该接口才能彻底终止分段上传任务并释放全部存储空间。
请调用 ListParts 检查任务的分片列表是否为空。

请求语法

DELETE /ObjectName?uploadId=uploadID HTTP/1.1
Host: Bucket.Endpoint
Date: date
Authorization: authorization

URI请求参数

名称 描述 是否必填
uploadId Initiate Multipart Upload响应返回的上传ID 是

请求头

请使用公共请求头。

请求体

无

响应语法

HTTP/1.1 status_code
x-wos-request-id: request id
Date: date
Content-Length: 0
Connection: close
Server: WS-Web-Server

响应头

请使用公共响应头。

响应体

无

特殊错误

Situation HTTP Status Error Code Message
所指定的 uploadId 不存在,可能是因为该 uploadId 无效,或者对应的分片上传任务已完成或已终止。 404 Not Found NoSuchUpload The specified upload does not exist. The upload ID may be invalid, or the upload may have been aborted or completed.

示例

DELETE /example-object?uploadId=VXBsb2FkIElEIGZvciBlbHZpbmcncyBteS1tb3ZpZS5tMnRzIHVwbG9hZ HTTP/1.1
Host: bucket.s3-cn-east-1.wcsapi.com
Date: Mon, 1 Nov 2010 20:34:56 GMT
Authorization: WOS AKIAIOSFODNN7EXAMPLE:0RQf3/cRonhpaBX5sCYVf1bNRuU=


HTTP/1.1 200 OK
x-wos-request-id: 996c76696e6727732072657175657374
Date: Mon, 1 Nov 2020 20:34:56 GMT
Content-Length: 0
Connection: close
Server: WS-Web-Server
本篇文档内容对您是否有帮助?
有帮助
我要反馈
提交成功!非常感谢您的反馈,我们会继续努力做到更好!